I’ve just committed the version 0.5.2 of CCS to the repository. I’ve just made some minor project configuration changes in order to be able to use CCS with OGRE 1.8. No modifications in the code have been made except a small change in the preprocessor definition that has to do with the Ogre version being used. You just need to add the preprocessor definition "CCS_OGRE_1_6" in the case you are using Ogre 1.6. Users who are using Ogre 1.7 or Ogre 1.8 (and hopefully Ogre 1.9) do not need to add any other preprocessor definition to the project configuration.